Server Outage

Incident Report for Mega Utilities

Resolved

Everything should be fixed now sorry for any inconvenience
Posted Oct 08, 2024 - 20:31 EDT

Update

We are continuing to work on a fix for this issue. - sorry for the duplicate update
Posted Oct 08, 2024 - 20:17 EDT

Update

Services are back but there's still some things we're fixing with the server,
Posted Oct 08, 2024 - 20:17 EDT

Identified

The issue has been identified and a fix is being implemented.
Posted Oct 08, 2024 - 19:58 EDT
This incident affected: Local Infrastructure (Local Server #1) and Bots (Log It - Discord, Log It - Revolt, Error - Revolt).