Internet Outage

Incident Report for Mega Utilities

Resolved

The incident has been resolved (was probably resolved A long time ago)
Posted Aug 12, 2024 - 17:22 EDT

Identified

Waiting for the ISP
Posted Aug 12, 2024 - 13:23 EDT
This incident affected: Local Infrastructure (Local Server #1) and Bots (Log It - Discord).